Skip to content

Commit

Permalink
freerdp: update to 3.13.0
Browse files Browse the repository at this point in the history
  • Loading branch information
Biswa96 committed Mar 10, 2025
1 parent 62e756f commit 33ab7ba
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 6 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
--- a/winpr/include/winpr/nt.h
+++ b/winpr/include/winpr/nt.h
@@ -1327,7 +1327,7 @@
FileMailslotSetInformation,
FileCompressionInformation,
FileObjectIdInformation,
- FileUnknownInformation1,
+ FileCompletionInformation,
FileMoveClusterInformation,
FileQuotaInformation,
FileReparsePointInformation,
--- a/winpr/libwinpr/nt/nt.c
+++ b/winpr/libwinpr/nt/nt.c
@@ -125,8 +125,8 @@
return "FileCompressionInformation";
case FileObjectIdInformation:
return "FileObjectIdInformation";
- case FileUnknownInformation1:
- return "FileUnknownInformation1";
+ case FileCompletionInformation:
+ return "FileCompletionInformation";
case FileMoveClusterInformation:
return "FileMoveClusterInformation";
case FileQuotaInformation:
15 changes: 9 additions & 6 deletions mingw-w64-freerdp/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
_realname=freerdp
pkgbase=mingw-w64-${_realname}
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
pkgver=3.12.0
pkgver=3.13.0
pkgrel=1
pkgdesc="Free implementation of the Remote Desktop Protocol (RDP) (mingw-w64)"
arch=('any')
Expand Down Expand Up @@ -32,11 +32,13 @@ makedepends=("${MINGW_PACKAGE_PREFIX}-cc"
source=("https://github.com/FreeRDP/FreeRDP/archive/${pkgver}/${_realname}-${pkgver}.tar.gz"
"001-nameless-union.patch"
"002-fix-missing-symbol.patch"
"003-dll-install-location.patch")
sha256sums=('837d91574b2f095fea2b7cf5951d9256ec06dc760034bfbf97cc1e85a5610878'
"003-dll-install-location.patch"
"004-replace-FileUnknownInformation1-FileCompletionInformation.patch")
sha256sums=('b0016e1280fc19a6bd43dbe789a378cf64a255403fd39a767afa7a59c1288e6b'
'445e9ce79a7783345082d0f6276c3baea50c2aeed8047c18846a37c8bef995e6'
'86adfa3e07eef9e2833559804ebcb97080140e9050df7ac5af8580310d30112a'
'c26ebfd8773d3a62199bb0a159b3ded9d16675356dc7f74e1a561b8e70868552')
'c26ebfd8773d3a62199bb0a159b3ded9d16675356dc7f74e1a561b8e70868552'
'2919c4ea5c68e441705baa9be388ccf4c2dda661ac6ba5fd84d2b677881a0407')

apply_patch_with_msg() {
for _patch in "$@"
Expand All @@ -52,7 +54,8 @@ prepare() {
apply_patch_with_msg \
001-nameless-union.patch \
002-fix-missing-symbol.patch \
003-dll-install-location.patch
003-dll-install-location.patch \
004-replace-FileUnknownInformation1-FileCompletionInformation.patch
}

build() {
Expand All @@ -69,7 +72,7 @@ build() {
_extra_config+=("-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF")
fi

CFLAGS+=" -Wno-incompatible-pointer-types"
CFLAGS+=" -Wno-deprecated-declarations -Wno-incompatible-pointer-types"

MSYS2_ARG_CONV_EXCL="-DCMAKE_INSTALL_PREFIX=" \
${MINGW_PREFIX}/bin/cmake.exe \
Expand Down

0 comments on commit 33ab7ba

Please sign in to comment.